F.A.Q.

Frequently Asked Questions

What operating systems does the Firearm Information Repository Environment support?

F.I.R.E. is written with .NET so it will run under any operating system with .NET installed. When installing under a compatible Windows operating system, you will be prompted to install .NET if necessary. For systems running an operating system other than Windows, you will need a version of .NET that runs on your machine. A good place to start is with MONO. Click here to read more about MONO. If you are interested in using F.I.R.E. on a non-Windows machine, please contact us.

What are the prerequisites for running the Firearm Information Repository Environment?

F.I.R.E. requires .NET 4.0 or higher to operate.

Why does the Firearm Information Repository Environment come in three different editions?

We decided to make three different editions to allow our customers the flexibility to only pay for what they are going to use. For example, if you are a firearm collector that does not have an FFL, why pay for that functionality. Likewise, if you only have a few firearms and just want to keep track of serial numbers and photos pertaining to them, you can use F.I.R.E. completely free of charge.

How do I get more information about the Firearm Information Repository Environment?
To communicate with us please use our contact page.